G-Drive xlim 500GB - not working and doing sound bip bip

User
Posts: 1
Joined: Dec 28th, '13, 10:32

G-Drive xlim 500GB - not working and doing sound bip bip

Postby barmanlife » Dec 28th, '13, 10:40

Hi, everybody.
I did purchaised the H-drive slim 500GB 2 years ago in order to do the back up of my iMac. It worked successfully, after a while I reconnected the G Drive at my I Mac and other Mac Os devices but did not worked.
When I connect it to the iMac or Macbook Pro I even cannot see it on the desktop or in the Utility disk and the G-Drive is doing a sound (Bip - bip.......).
Can enyone help me please, how can I erease the G-drive and re-use it?
Cheers and happy new years.

Moderator
User avatar
Posts: 510
Joined: Feb 6th, '13, 10:44

Re: G-Drive xlim 500GB - not working and doing sound bip bip

Postby Dustin F » Dec 30th, '13, 09:19

Hi barmanlife,

Thanks for posting. If you are getting a constant beeping/clicking sound coming from the drive it could be one of two things. It could be that the drive simply isn't getting enough power, since you have tried it on multiple computers it isn't just a fussy usb port, I would suggest swapping usb cables as that is sometimes the culprit. If that doesn't work unfortunately there is a mechanical issue with the drive and should be replaced. A RMA to have it replaced under warranty can be filed here. http://www2.hgst.com/warranty/index_gtech_serial.do
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

Return to G-DRIVE slim



cron
Fatal: Not able to open ./cache/data_global.php