Drive stopped mounting

User
Posts: 1
Joined: Oct 11th, '13, 12:35

Drive stopped mounting

Postby Ian+matt38 » Oct 11th, '13, 12:42

I have had this gdrive moble for over a year and it just stopped mounting on my macbook which is about 4 months old. It had been mounting fine for months and today just kicked off. It shows up in my disk utility but will not mount finder. PLEASE HELP. I have YEARS worth of work on here that cannot be lost. What can I do? ian@iangoolsby.com

Moderator
User avatar
Posts: 363
Joined: Feb 6th, '13, 10:44

Re: Drive stopped mounting

Postby Dustin F » Oct 14th, '13, 11:06

Hi ian+matt38,

Thanks for posting. You said the drive is listing in finder. Is it listing the logical partition (the drive name) grayed out? If so have you gone into the first aid tab and attempted a verify and repair disk on it?
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

User
Posts: 3
Joined: Nov 1st, '13, 12:26

Re: Drive stopped mounting

Postby rlfish0630 » Nov 1st, '13, 12:36

I'm having the same problem mounting my G-Drive after having used it successfully for years. Where's this "first-aid" tab? Any other suggestions?

Moderator
User avatar
Posts: 363
Joined: Feb 6th, '13, 10:44

Re: Drive stopped mounting

Postby Dustin F » Nov 4th, '13, 11:37

Hi rlfish0630,

Thanks for posting. If the drive is listed under disk utility when you first click on the drive is the left column the pane on the right will be on first aid by default. Here is a guide on the basics of disk utility.

http://mac.tutsplus.com/tutorials/os-x/ ... kutillity/
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

Return to G-DRIVE mobile USB



cron
Fatal: Not able to open ./cache/data_global.php