Disk not properly ejected

Posts: 2
Joined: Apr 18th, '13, 06:21

Disk not properly ejected

Postby hmcwilliams » Apr 18th, '13, 06:27

I have two 2TB G drives connected to my iMac. One is by firewire and the other by USB. The USB-connected drive is set up to be used as the backup disk by Time Machine. Lately it has been randomly unmounting (about every minute) and then i get the "Disk not properly ejected" message. I have tried pushing in the connections firmly to make sure it is not a connection issue. Is there something else I should try, such as daisy-chaining them using another Firewire cable? Please help as this is driving me crazy.

User avatar
Posts: 367
Joined: Feb 6th, '13, 10:44

Re: Disk not properly ejected

Postby Dustin F » Apr 18th, '13, 07:25

Hi hmcwilliams,

Thanks for posting. You could try swapping to a different usb cable to see if the problem persists as well as changing usb ports on the computer. If the problem does persist trying it via firewire could be one thing to try. Since it is the backup drive I take it that it is usually on all the time, I would recommend to have that be the first drive in the chain. If the problem does persist on one or both of the connections there may be an issue with the controller card on the unit. If the drive is still in warranty you can file a RMA to have it replaced from our website. http://prod.g-technology.com/support/warranty_rma.cfm

G-Technology Support

Posts: 2
Joined: Apr 18th, '13, 06:21

Re: Disk not properly ejected

Postby hmcwilliams » Apr 18th, '13, 07:32

Thanks Dustin. I will try what you suggest.

Posts: 1
Joined: Apr 16th, '13, 09:28

Re: Disk not properly ejected

Postby jtonk » Apr 19th, '13, 00:32


I have the same issue with a single 2TB G-Drive over firewire 800. The message appears only when I am away from the computer, it stays connected or reconnects after the message. I have the idea it has something to do with power management and the drive not awaking fast enough, because the disk goes to sleep en spins up again quite often, but I can't really tell what makes it awake.

I tried disabling some of the applications that rely on the disk, but no succes yet. I use the disk as time machine backup and backup for large files (disk images/movies etc).

I will try to see if it persist when connected over USB. Does it help to reformat the drive? I prefer not to.



Return to G-DRIVE

Fatal: Not able to open ./cache/data_global.php