G-Drive not showing up?

Posts: 1
Joined: Jan 28th, '13, 09:26

G-Drive not showing up?

Postby esmcadams » Jan 28th, '13, 09:30

I just brought my new G-Drive home to use with 2 macbooks, using an airport extreme. I connected the G-Drive unit to the airport extreme and the LED light lit up. However, I cannot see the G-Drive on the macbook and can't set up Time Machine. The paperwork says it will work with Time Machine right out of the box. Am I not waiting long enough? Did I do something wrong? Is the unit dysfunctional? Any help would be greatly appreciated. The unit has been connected to the Airport for almost an hour without showing up on the macbook.


Posts: 175
Joined: Aug 27th, '12, 12:16

Re: G-Drive not showing up?

Postby Gene G » Jan 28th, '13, 14:14


Thanks for your post. Have you tried connecting directly to your computer? Have you setup the Airport Extreme to use the G-DRIVE? Have you tried different cables? Please let me know if you have any questions.

Gene Gilbert
G-Technology Tech Support

Return to G-DRIVE

Fatal: Not able to open ./cache/data_global.php