Just picked up a G-Connect and NOT happy

User
Posts: 2
Joined: Apr 22nd, '12, 17:13

Just picked up a G-Connect and NOT happy

Postby toddhawkins » Apr 22nd, '12, 17:20

While I was at NAB I picked up a G-Connect (From Unitek) and I would be doing great if the thing worked. The Wifi is not working at all and the status light has a solid red light. I followed the reset to default settings per the documentation online only to have that do nothing as well. I can plug it in to my computer as a hard rive and that works but that's about it. Let me know what I should do next.

Todd

Moderator
User avatar
Posts: 56
Joined: Dec 21st, '11, 14:23

Re: Just picked up a G-Connect and NOT happy

Postby Brandon P » Apr 23rd, '12, 13:03

Hello toddhawkins,

Please let me know the process you used when starting with the product.

Did you plug in the G-CONNECT with ethernet out of the box to attempt an update?

Did you plug in USB first to start moving data to the drive?

Please let me know the exact steps you took when attempting the setup of the device
Brandon P
G-Technology Technical Support

User
Posts: 2
Joined: Apr 22nd, '12, 17:13

Re: Just picked up a G-Connect and NOT happy

Postby toddhawkins » Apr 23rd, '12, 23:52

When I first got it the wireless worked fine and I followed all the instructions and set it all up and had it working as far as a hotspot. I actually did all this setup while I was in Vegas just to verify it even worked even though I had no content on it. It worked fine. When I got home the other day I plugged it in to USB to transfer over some video files. After I was done with that I unhooked it and set it back up as a hotspot and could never and still cannot see it and connect to it.

Moderator
User avatar
Posts: 56
Joined: Dec 21st, '11, 14:23

Re: Just picked up a G-Connect and NOT happy

Postby Brandon P » Apr 24th, '12, 07:57

Hello,

While you had it working in Vegas did you hook it up with ethernet to get the update?

If you have not had a chance to do the update this process should help fix the issue:

- Plug the ethernet connection into the G-CONNECT so that it is getting an internet connection from your router.
- Power on the G-CONNECT and once the WiFi light goes on press and hold the WiFi button on the side of the G-CONNECT
- You will notice the lights blinking on Status and a quick flash on PWR/HDD. Continue to hold the WiFi button until you see the lights on the ethernet go out. They will come back on and it will attempt the update process.
- You will not it is going through the update when the WiFi and Status lights start blinking back and forth alternating. This process can take up to 20 minutes to finish. Once it does the Status light should be off and the unit should now be working. You will have to setup the network SSID again but the files inside will remain.
Brandon P
G-Technology Technical Support

User
Posts: 1
Joined: Jul 24th, '12, 10:21

Re: Just picked up a G-Connect and NOT happy

Postby olam4u » Jul 24th, '12, 10:30

i had the same problem

your advice was perfect to solve that issue

now my g - connect hdd works excellent with i pad new via wifi

thanks Brandon P

Moderator
User avatar
Posts: 56
Joined: Dec 21st, '11, 14:23

Re: Just picked up a G-Connect and NOT happy

Postby Brandon P » Jul 27th, '12, 08:27

olam4u,

Thank you for the feedback and very glad to hear that it worked out.
Brandon P
G-Technology Technical Support

User
Posts: 1
Joined: Nov 4th, '13, 21:19

Re: Just picked up a G-Connect and NOT happy

Postby rbangs » Nov 4th, '13, 21:40

I tried the steps listed by Brandon. I cannot get the ethernet lights to go out when pressing and holding the WiFi button.

Thus, the unit does not appear to be getting the update.

Help!

Moderator
User avatar
Posts: 508
Joined: Feb 6th, '13, 10:44

Re: Just picked up a G-Connect and NOT happy

Postby Dustin F » Nov 5th, '13, 08:47

Hi rbangs,

Thanks for posting. For clarity, the wifi button is the smaller button next to the power button and the ethernet lights are on the port itself where the cable plugs in (one green, one orange) please make sure you are getting these lights coming on to begin with. Just after the unit is turned on when the wifi light on the front of the unit turns on you will need to hold the button for at least ten seconds. The lights with the cable will turn off keep holding until the lights come back on then release the wifi button and you should get the status and wifi light on the front of the unit alternating back and forth. Please let me know if this helps.
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

User
Posts: 2
Joined: Nov 30th, '13, 09:36

Re: Just picked up a G-Connect and NOT happy

Postby chotroi » Nov 30th, '13, 09:54

Hi,

I just got G-Connect from Frys. After I followed the steps and successfully set up, my G-Connect network status was LIMTED so I cannot use. Please help.

Thanks.

Moderator
User avatar
Posts: 508
Joined: Feb 6th, '13, 10:44

Re: Just picked up a G-Connect and NOT happy

Postby Dustin F » Nov 30th, '13, 11:54

Hi chotroi,

Thanks for posting. Do you have an ethernet cable plugged into the g-connect for internet pass through or is it running as a stand alone unit? If you have the ethernet plugged in and you have that status the firmware may need to be updated to correct. If you are using the device stand alone that is normal to get a limited or local only status and would not stop you from using it as a media sharing device.
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

Next

Return to Wi-Fi Troubleshooting



Fatal: Not able to open ./cache/data_global.php