G Drive not showing up on my desktop or in disk utility

User
Posts: 1
Joined: Jul 21st, '14, 16:47

G Drive not showing up on my desktop or in disk utility

Postby ddwyatt5 » Jul 21st, '14, 17:45

Hi, I recently received a replacement G Drive under warranty. This drive is my time machine backup. The first time I connected it to my new iMac desktop, everything seemed to be great and a back-up was performed. Since then, however, whenever I try connecting the G Drive, I get a pop up message saying that the disk was not ejected properly. I did properly eject the drive when I was able to, but ever since the first time it was connected, the new G Drive has not shown up on my desktop or in Disk Utilitiy when I try connecting it.

When I try connecting the G Drive to my older iMac, it shows up on the desktop, but continues to say it was not ejected properly even when I do eject it properly from that computer.

I have an older G Drive that I use to back up my photos. It continues to appear on the desktop and seems to have no issues.

My new iMac is a late 2013 27" model (purchased Dec. 24, 2013) running Mavericks - OS X 10.9.4 I am connecting the drive via USB port.

I would really appreciate some help, if anyone has any idea why this G Drive is not showing up on my new iMac.

Thanks!

Moderator
User avatar
Posts: 510
Joined: Feb 6th, '13, 10:44

Re: G Drive not showing up on my desktop or in disk utility

Postby Dustin F » Jul 22nd, '14, 07:07

Hi ddwyatt5,

Thanks for posting. Have you tried an alternate usb cable to see if you get the same result. When you change computers are you using the same power adapter or a different adapter?
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

Return to General Troubleshooting



cron
Fatal: Not able to open ./cache/data_global.php