G-Drive 4T Failing Mac Time Machine Backups

User
Posts: 6
Joined: Nov 25th, '13, 05:37

G-Drive 4T Failing Mac Time Machine Backups

Postby davidghawkins » Nov 25th, '13, 05:48

My new 4T G-Drive worked fine when first set up for Mac time machine backups, but fails on subsequent scheduled backups. Get message backup failed due to "an error". Then, I try to dismount it and it won't dismount or eject; I have to force eject. Then I shut it down and restart it, and the backup works again . . . once, then fails again. Cable is the Firewire that was supplied with the G-Drive.

Moderator
User avatar
Posts: 368
Joined: Feb 6th, '13, 10:44

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby Dustin F » Nov 25th, '13, 11:35

Hi davidghawkins,

Thanks for posting. It sounds like you are using a G-Drive generation 5 (usb 3 and firewire 800). We have seen some issues with the drive not properly waking up from the firewire signal after spinning down. We have developed a firmware fix for this issue. The firmware update should be run with the firewire connection. The drive you are updating should be the only external drive attached the time. You can find the firmware update here. http://support.g-technology.com/support ... -downloads
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

User
Posts: 6
Joined: Nov 25th, '13, 05:37

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby davidghawkins » Nov 25th, '13, 18:35

Thank you for this reply. I have downloaded and installed the firmware update, and that seems to have solved the problem.

User
Posts: 6
Joined: Nov 25th, '13, 05:37

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby davidghawkins » Nov 26th, '13, 08:43

I spoke too soon. Today, the problem is back in full. Every time the backup is attempted, it fails, I have force eject the disk, turn it off, turn it back on and re-start Time Machine, at which point it does back up properly. But, an hour or two later, it fails the next backup.

Moderator
User avatar
Posts: 368
Joined: Feb 6th, '13, 10:44

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby Dustin F » Nov 27th, '13, 08:15

Hi david,

We have sometimes seen the issue continue after the firmware update. In most cases the issue post update can be resolved by resetting the SMC and PRAM on your computer. If it still persists after this please let me know.

SMC Reset. http://support.apple.com/kb/ht3964

PRAM Reset. http://support.apple.com/kb/ht1379
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

User
Posts: 6
Joined: Nov 25th, '13, 05:37

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby davidghawkins » Nov 29th, '13, 06:42

Did this, but only helped somewhat. Now the problem happens 50% of the time instead of 100%. In other words, sometimes the backup runs fine, and then sometimes the above listed failure happens again. It just happened how again, a few minutes ago.

Moderator
User avatar
Posts: 368
Joined: Feb 6th, '13, 10:44

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby Dustin F » Nov 30th, '13, 11:41

Hi david,

There are a couple of options. Since it is only time machine backups you could use the drive with usb which the problem does not occur on that connection or you can send me a private message so we can discuss setting up a replacement of the unit.
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

User
Posts: 6
Joined: Nov 25th, '13, 05:37

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby davidghawkins » Nov 30th, '13, 16:03

I may have found the cause of and the solution to the problem, but I don't want to claim full victory yet. I want to let it run for a full 24 hours of backups to make sure the problem does not recur. I'll let you know tomorrow.

User
Posts: 6
Joined: Nov 25th, '13, 05:37

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby davidghawkins » Dec 4th, '13, 07:57

The solution I tried didn't work, so I put on the USB cable, and now after several days it is working very well. This isn't the ideal solution, not being able to use firewire, however, since I'm using the disk strictly for backup, I can live with it.

User
Posts: 4
Joined: Mar 2nd, '14, 14:03

Re: G-Drive 4T Failing Mac Time Machine Backups

Postby jon » Mar 2nd, '14, 19:30

After struggling with this for the past month, I found this thread.

Thanks for the information. I've updated the firmware for my new 4TB G-Drive and cleared the NVRAM (am running 10.7.5 Server on a Mac Mini) and SMC. The backups continued for a few hours but are now failing again.

The Time Machine backup fails with the error:

<timestamp> com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HoustUUID path <path-to-backupdb/server> size:37
<timestamp> com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HoustUUID path <path-to-backupdb/server> size:37
<timestamp> com.apple.backupd: Backup failed with error: 2

After this, I cannot unmount or eject the drive as apparently something is holding open a file. My only recourse is to reboot the server.

The backup drive is first in a FW800 chain of G-Drives, with one FW400 older G-Drive at the end of the chain. The first three are FW800 and the last is a FW400 (using a FW800->FW400 cable for connection). All drives are accessible normally with no errors I've found elsewhere.

The USB isn't really an option as I'm already running a fully consumed powered USB hub in addition to the native USB ports on the Mac Mini to manage other peripherals.

Let me know if there is anything I can collect on the system that might be helpful.

Jon

Next

Return to G-DRIVE



cron
Fatal: Not able to open ./cache/data_global.php