G-Drive keeps changing permissions

Posts: 1
Joined: May 2nd, '13, 08:31

G-Drive keeps changing permissions

Postby ziemski » May 2nd, '13, 09:43

Brand new 1TB G-Drives keeps changing permissions: I have new drives, one for Time Machine and one for CCC clone.
They worked fine but suddenly get Time Machine message "Time Machine couldn't complete Time Machine backup to Time Machine. Files can't be copied onto backup disk because it appears to be read only. You may need to repair or reformat the disk using Disk Utility. If the disk can't be repaired, you must find a different disk for backups."
The second drive uses CCC. I get an error message "CCC backups not writable therefore CCC cannot use it as a destination. Please choose another destination."

I have reformatted these many times, manually changed the settings to "everyone" in the get info portion and it may work at first but they both go back to unwritable all the time.

Spoke with G-Technology customer support yesterday and did all the things they asked, which I had already done, but this time they suggested I eject and turn off all drives and add one drive at a time and see if the problem is resolved. It was for the time they asked me to try Time Machine and CCC but now the error messages are back.
Does anyone have any similar problems or suggestions to repair this once and for all or should I contact G-Drive and have them sent back??

Posts: 1
Joined: May 23rd, '13, 09:08

Re: G-Drive keeps changing permissions

Postby fruch » May 23rd, '13, 09:13

Yes, I had this problem and eventually g-tech technical support admitted it was a known problem when connecting over firewire 800. I sent my drive back, just got a replacement and... it has the same problem. Makes the drive basically worthless for me. They won't give a refund either, just offer to replace it with another equally faulty drive. The other annoying thing is that when this happens the drive won't eject so I have to shut down the computer to safely remove it.


Posts: 175
Joined: Aug 27th, '12, 12:16

Re: G-Drive keeps changing permissions

Postby Gene G » May 23rd, '13, 12:32


Thanks for your post. There is a firmware update coming soon that to address this issue. I will keep you updated.

Gene Gilbert
G-Technology Tech Support

Posts: 1
Joined: Feb 11th, '14, 13:41

Re: G-Drive keeps changing permissions

Postby shyguy » Feb 11th, '14, 13:51

I have two 4-GB Gdrives and an 8 TB G-RAID and am experiencing the same problems with disc permissions. I can fix the problem temporarily by restarting the computer or changing the permissions back in get info (doesn't always work), but, really?
I see that Gene G posted that there will be a firmware update last May 23rd. It's been over 8 months. How do I get the firmware update? Will it require backing up everything?

Posts: 2
Joined: Jul 15th, '14, 11:08

Re: G-Drive keeps changing permissions

Postby fatcab » Jul 15th, '14, 11:11

Hey all.

I got the same issues with this drive. First I thought my Mac or Thunderbolt Display were faulty.

I found a newer firmware Update on the HSGT website.

Could you please confirm, that this update fix this issue finally?

thanks a lot.


User avatar
Posts: 783
Joined: Feb 6th, '13, 10:44

Re: G-Drive keeps changing permissions

Postby Dustin F » Jul 16th, '14, 08:43

Hi André,

Thanks for posting. If you are having trouble with the drive over firewire after 10 minutes or more on a unit that has usb 3 but is fixed temporarily by the drive being power cycled then the firmware listed on the g-technology site would resolve the issue. The firmware can be found in the downloads section of the g-technology website


G-Technology Support

Posts: 2
Joined: Jul 15th, '14, 11:08

Re: G-Drive keeps changing permissions

Postby fatcab » Jul 24th, '14, 01:52

Hey Dustin.

Thanks for your answer.

I already installed the firmware update, but the issue persists. A also double checked, if the firmware is really installed.

I also changed the used FW800 cables, connected it directly to the Mac and / or via the Thunderbolt Display build in hub.

In the meantime I also replaced the TB Display and the MacBook Pro had a new logic board. So I think, this is a mess.

I bought the hard drive in an Apple Store and it doesn't work well with Apple devices via FW? Really.

I will contact the support for an option.

Posts: 1
Joined: Oct 9th, '14, 14:47

Re: G-Drive keeps changing permissions

Postby ToJohnPaul » Oct 9th, '14, 14:52

There is a simple fix.

If you call tech support they will tell you that you need to update your firmware. The firmware update doesn't work. I've tried it twice.

The problem is that if the drive is left alone for a period of time, it is programmed to fall "asleep" to conserve power. However, it doesn't know how to wake itself up properly.

So you need to set your Mac to be in charge of putting the drive to sleep and waking it up. You do this by selecting the "Put hard drives to sleep when possible" setting under the Energy Saver menu in Settings.

Now your Mac will put the drive to sleep and wake it up.

Return to G-DRIVE

Fatal: Not able to open ./cache/data_global.php