G drive slim 500 GB

User
Posts: 1
Joined: Nov 11th, '12, 09:50

G drive slim 500 GB

Postby welbied » Nov 11th, '12, 09:54

I can not access files in my external disk because when i connect it the light on it turns on but neither mac nor windows recognize it.

Moderator
Posts: 175
Joined: Aug 27th, '12, 12:16

Re: G drive slim 500 GB

Postby Gene G » Nov 12th, '12, 08:43

Hi,

Thanks for your post. Can you hear the drive spinning? Do you hear any unusual sounds or activity? Are you using the cable supplied with the drive? Have you tried another cable? Does it appear in Disk Utility? Please let me know if you have any questions.

Regards,
Gene Gilbert
G-Technology Tech Support
g-technology.com

User
Posts: 1
Joined: Feb 6th, '13, 06:17

Re: G drive slim 500 GB

Postby stephs » Feb 6th, '13, 06:24

I am experiencing the same issue. When I plug it in, I can hear the drive spinning. There also appears to be some unusual noise. I only use the cable supplied with the drive and do not have an alternate cable to try. The drive is not appearing anywhere on my computer. My drive is only 2 months old and still under warranty but I would need to remove all my information before I can send it in. This however is not possible when I cannot access the drive. I am desperate need to access the information on the drive. Please help!

Moderator
Posts: 175
Joined: Aug 27th, '12, 12:16

Re: G drive slim 500 GB

Postby Gene G » Feb 6th, '13, 15:24

Hi Stephs,

Thanks for your post. What is the unusual noise like, is it clicking, grinding, or scratching? Any sound that is unusual is not a good sign. Does it appear in Disk Utility? Please let me know if you have any questions.

Regards,
Gene Gilbert
G-Technology Tech Support
g-technology.com

User
Posts: 2
Joined: Feb 27th, '13, 12:02

Re: G drive slim 500 GB

Postby afewimages » Feb 27th, '13, 12:06

Hi,
i just received my slim and after connecting it makes an awful noise (scratching, beeping...) after which it stopped after one minute and became visible on the mac. Is this normal?

steven

User
Posts: 1
Joined: Feb 28th, '13, 12:29

Re: G drive slim 500 GB

Postby gavlaaaaarrrrr » Feb 28th, '13, 12:32

Hi i have the same problem when i connect the drive to my mac it does not show up anymore the light is on on the drive and there is a clicking sound??

User
Posts: 2
Joined: Feb 27th, '13, 12:02

Re: G drive slim 500 GB

Postby afewimages » Mar 1st, '13, 02:35

Hi,

i have the same issue. When starting up the drive it makes a lot of noise for about half a minute after which it becomes available in disk utility. It is connect through a hub. Could this be a probelm?

steven

Moderator
User avatar
Posts: 369
Joined: Feb 6th, '13, 10:44

Re: G drive slim 500 GB

Postby Dustin F » Mar 1st, '13, 08:20

Hi afewimages,

Thanks for posting. Yes having it plugged into a hub can sometimes cause trouble. The drive draws power from the usb cable and hubs cannot always provide enough power. The clicking noise could be the drive attempting to spin up. This is common on hubs, laptops, and frontside usb connections of desktops. Since you are using a hub try connecting it directly to the computer to see if that helps. If this is a laptop and still has trouble directly connected try it on a desktop to see if it has the same trouble. if so you can try swapping the usb cable. Let me know if you have any more questions.
Regards

Dustin
G-Technology Support
twitter.com/GTech_Support

User
Posts: 1
Joined: Jun 14th, '13, 16:49

Re: G drive slim 500 GB

Postby vasbinda » Jun 14th, '13, 17:02

Hello,

While reading the previous posts, I noticed that no one from G-Tech has addressed or corrected the original issue brought up (which my g-drive slim is also experiencing). Please provide a solid response as to what I should do with this currently useless external hard drive. Should I take it back to the Apple store where I bought it, should I send it back to the company, should i use it as a paperweight......i'm lost here.

When plugged into the MacBook Pro (with original cord) the unit activates itself and the power light turns on. However nothing shows up on the MacBook indicating that it is connected. NOTHING. Please let me know what I should do.

Thanks

Moderator
Posts: 175
Joined: Aug 27th, '12, 12:16

Re: G drive slim 500 GB

Postby Gene G » Jun 25th, '13, 09:42

Hi,

Thanks for your post. If you are getting a rapid clicking, it generally indicates the drive may not be getting enough power. You can often rectify this by making sure you are using a short, 18" cable and making sure the Energy Saver Preferences are set for performance and not battery life, such as making sure the sleep settings are disabled for the drives. Does the drive appear in Disk Utility? If so, is the volume greyed out? If so, you may have a damaged directory, which can be caused by improperly disconnecting the drive or losing power. Please let me know if you have any questions.

Regards,
Gene Gilbert
G-Technology Tech Support
g-technology.com

Return to G-DRIVE slim



Fatal: Not able to open ./cache/data_global.php