CompanyLogo
Search Advanced Search
Categories
General Questions (53)
Studio Series (20)
Evolution Series (27)
G-DRIVE Family (41)
G-RAID Family (51)
G-SPEED/G-SAFE Family (52)
G-CONNECT (53)
G-MINI (16)
G-SATA (15)
Search
Advanced Search
FAQs
Search our FAQ to find resolutions to common issues.
Can I use 3rd party hard drives in my GSafe/GSpeed units?

G-Technology has not tested using alternate drives in the multi bay units. Using 3rd party drives is not recommended and will void your warranty. Alternate drives will most likely work, but could provide lower performance. It is also very important that all drives in the unit be matched, brand and model. Inserting an unmatched drive can result in data loss.

 


Print  Email  Save  Notify Me  Delete from Favorites 
Article ID: 53 Article Created: 03-10-2011 15:51 PMLast Modified: 03-10-2011 15:51 PM

How well did this article answer your question? 100% 75% 50% 25% 0%

Most Recently Viewed Articles
G-SPEED Q LED Visual Notifications
 View this article to determine what the LED colors on your G-SPEED Q mean....
External Drive Troubleshooting - Mac
Basic steps for troubleshooting your G-Technology external drive on the Mac...
Can I boot my Mac from a Thunderbolt drive?
The G-RAID Thunderbolt is not supported as a boot volume....
Formatting your drive for both Mac and Windows using ex-FAT
 This article contains information how to format your G-Technology hard drive for use with both Windows and Mac using the ex-FAT format....
How to format/reformat your drive for Mac (HFS+)
 Follow these steps to format your drive for use on the Mac:...
Formatting NTFS for Windows
 This article contains information on how to format your G-Technology Hard Drive in NTFS for use with Windows....
External Hard Drive Encryption for Mac
 Steps to encrypt an external hard drive....
What brand of Hard Drive is inside my G-Technology drive?
G-Technology is exclusively using HGST brand hard drives in all products.  ...
Quick Setup for G-Technology Products
    ...
My drive was working; it powers up but I can’t seem to access it?
 Mac and Windows external drive troubleshooting....